Jump to content
IllidanS4

ostatní 0.3.8 zrušeno?

Recommended Posts

Ahoj, přátelé, tak se nám dějí prapodivné věci. Pokud jsme se neposunuli v čase na 1. dubna, vypadá to, že 0.3.8 skončí tak, jak rychle začala. Tento krátký příspěvek od tvůrce SA-MP tvrdí, že vývoj SA-MP bude rozdělen do dvou větví a vlastní modely budou ve větvi "0.3.7-DL". Trochu nechápu, jak si představuje, že lidi budou mít nainstalovány dvě verze SA-MP, a jak servery budou rozdělovat svoje komunity pro obě větve, ale uvidíme, co budoucnost přinese.

 

Začal jsem takovou malou anketu o tom, aby SA-MP bylo open-source. Pokud si to přejete, dejte prosím hlas, díky!

Edit: Promptně smazáno. Nevadí, dalo se to čekat. Archivováno zde.

Edited by IllidanS4

Sdílet tento příspěvek


Link to post
Share on other sites

Mít dvě verze samp je samo o sobě skoro nemožný... Po 10 letech přišel s něčím co MTA umí snad od začátku, IV-MP to umělo daleko lépe a on to ořízne ( jako všechno co dělá ) a pak to ještě zruší..Asi narazil na problém se kterým nemůže hnout tak to raději ukončí

Sdílet tento příspěvek


Link to post
Share on other sites

No do prdele..

Jen vstanu a přečtu si toto a už mám zas špatnou náladu ale tak jak se psalo už výše byla to RC verze no :/ Ale i tak zahodit takovou práci.

Každopádně to rozdělení ten SA-MP akorát víc zníčí je tu maximalně možnost vzít 0.3.8 RC-4.1 a s tím pracovat pro všechny kdo budou chtít hrát na serverech. Upřímně si myslím že hráče by akorát unavovalo pořád přepínat verze a pak by SA-MP zanikl úplně.

S tím open-source tak uplně nesouhlasím protože si vem že by např.40 lidí dělalo svojí verzi a každej by to nějak prezentoval a pak by vtom byl úplnej bordel

tvůrci by si to pojmenovali po sobě a šlo by to úplně do háje jak jsem psal každej by měl svoje a hrači by  po pár týdnech víc museli stahovat verze než si užívat hru.  Takže já si stojím zatím že bych prostě např na mém serveru měl prostě 0.3.8 RC-4.1 a s tím bych skončil.

A k tomu open-source bylo by možná lepší kdyby Kalcor dal kod od SA-MP někomu dalšímu nebo si vzal víc lidí na pomoc ve tvorbě co zvládnou to co on ne. Protože takhle se můžem rozloučit a říct jen Měj se SA-MP.

Každopádně pěkný příspěvek

Sdílet tento příspěvek


Link to post
Share on other sites

Co mělo být vůbec v 0.3.8?

 

 

 

/// edit: Obecně k tomu mazání, nehorázně mě to sere na tom sa-mp fóru, jak beztrestně a bez informací mažou topicy. Mně smazali už v nejméně dvou případech

 

//edit2: http://forum.sa-mp.com/showthread.php?t=644105 (už jsem našel, kdyby někoho také zajímalo)

Sdílet tento příspěvek


Link to post
Share on other sites

Zatim to vypada, ze verze 0.3.7 a verze 0.3.7-DL nebudou navzajem kompatibilni, takze hraci budou muset pokazde instalovat klienta podle toho, jakou verzi bude pouzivat server. Diky tomu je 0.3.7-DL v podstate nepouzitelne, protoze vetsina velkych serveru nejspise zustane na verzi 0.3.7, protoze by se na jejich servery nemohlo pripojit spoustu hracu.

 

Jedine reseni je domluvit se, ze vsechny vetsi SA-MP servery budou pouzivat SA-MP 0.3.7-DL aby hraci nemuseli instalovat pokazde jineho klienta, ale i tak je to zbytecna komplikace a zbytecne to rozdeli celou SA-MP komunitu na dve casti. Je skoda, ze nezustalo SA-MP 0.3.8 tak jak bylo, servery, ktere by nechtely pouzivat vlastni modely objektu a skinu, si mohly vypnout tuto moznost pomoci "useartwork" v server.cfg.

 

Kazdopadne uvidime jak to nakonec bude a jak se k tomu Kalcor vyjadri.

Edited by niCe

Sdílet tento příspěvek


Link to post
Share on other sites

Zatim to vypada, ze verze 0.3.7 a verze 0.3.7-DL nebudou navzajem kompatibilni, takze hraci budou muset pokazde instalovat klienta podle toho, jakou verzi bude pouzivat server. Diky tomu je 0.3.7-DL v podstate nepouzitelne, protoze vetsina velkych serveru nejspise zustane na verzi 0.3.7, protoze by se na jejich servery nemohlo pripojit spoustu hracu.

 

Jedine reseni je domluvit se, ze vsechny vetsi SA-MP servery budou pouzivat SA-MP 0.3.7-DL aby hraci nemuseli instalovat pokazde jineho klienta, ale i tak je to zbytecna komplikace a zbytecne to rozdeli celou SA-MP komunitu na dve casti. Je skoda, ze nezustalo SA-MP 0.3.8 tak jak bylo, servery, ktere by nechtely pouzivat vlastni modely objektu a skinu, si mohly vypnout tuto moznost pomoci "useartwork" v server.cfg.

 

Kazdopadne uvidime jak to nakonec bude a jak se k tomu Kalcor vyjadri.

A co kdyby všechny servery zůstali na 0.3.8 RC 4 neboli na poslední verzi 0.3.8 která byla oficialně spuštěna ?

Nebylo by to lepší ? Že by všechny servery prostě šli na 0.3.8 co je k dispozici.

 

Edit:

Třeba jak by Kalcor viděl  zájem tak by to zkusil dodělat a nemuselo by se to takhle rozdělovat.

Sdílet tento příspěvek


Link to post
Share on other sites

A co kdyby všechny servery zůstali na 0.3.8 RC 4 neboli na poslední verzi 0.3.8 která byla oficialně spuštěna ?

Nebylo by to lepší ? Že by všechny servery prostě šli na 0.3.8 co je k dispozici.

 

Edit:

Třeba jak by Kalcor viděl  zájem tak by to zkusil dodělat a nemuselo by se to takhle rozdělovat.

 

Ta verze 0.3.7-DL bude v podstate to same co 0.3.8 RC 4. Jinak take si myslim, ze kdyby vetsina serveru pouzivala 0.3.7-DL, tak by to snad Kalcora primelo, aby ty vlastni modely a skiny nechal v SA-MP defaultne. Ale je to zbytecny a slozity boj.

Sdílet tento příspěvek


Link to post
Share on other sites

Ta verze 0.3.7-DL bude v podstate to same co 0.3.8 RC 4. Jinak take si myslim, ze kdyby vetsina serveru pouzivala 0.3.7-DL, tak by to snad Kalcora primelo, aby ty vlastni modely a skiny nechal v SA-MP defaultne. Ale je to zbytecny a slozity boj.

Taky pravda.

 

Ale když už bude 0.3.7 DL tak ať je kompatibilní s 0.3.7 protože jinak to hráče bude brutálně mást a už vidím (někteří hráči se najdou co to nepochopí)

Dám příklad:

Uživatel bude mít verze 0.3.7 a bude chtít jít na server 0.3.7 DL ovšem jsou i méně všímaví hráči tak budou spamovat na webech že mají 0.3.7 a  nemůžou se připojit že máme někde na serveru chybu a když jim řekneš že musí mít upravenou verzi 0.3.7 DL tak si budou akorát stěžovat.

Sdílet tento příspěvek


Link to post
Share on other sites

Ono s tou možností pro hráče, že budou moct hrát na serverech, které po nich nechtějí stáhnutí fůry modelů, to není zas tak špatný nápad, ale jako vždy byl proveden naprosto nesmyslně. Tedy za předpokladu, že to bude záležitost přepínání mezi dvěma verzemi. Přinejmenším česká komunita rozhodně nepotřebuje další rozdělení.

 

Pracuji na vývoji pluginu YSF. Pokud to nebude tak velký problém, pokusím se nějak ty verze spojit, aby hráči s jednou verzí mohli hrát s těmi, co mají druhou. Pokud 0.3.7-DL bude jen záležitost jedné přidané funkce (jako je třeba verze serveru pro 1000 lidí), mohla by to být jen záležitost změny kontroly verze a úpravy protokolu.

Sdílet tento příspěvek


Link to post
Share on other sites

Ono s tou možností pro hráče, že budou moct hrát na serverech, které po nich nechtějí stáhnutí fůry modelů, to není zas tak špatný nápad, ale jako vždy byl proveden naprosto nesmyslně. Tedy za předpokladu, že to bude záležitost přepínání mezi dvěma verzemi. Přinejmenším česká komunita rozhodně nepotřebuje další rozdělení.

 

Je pravda, ze nekteri majitele serveru nad tim absolutne nepremysli a pridali by na server stovky zbytecnych objektu a stahovani po pripojeni by trvalo nekolik desitek minut. Kazdopadne me to zruseni hodne mrzi, protoze jsem ztratil skoro dva tydny prace, kterou jsem venoval pridavani featur zalozenych na vlastnich modelech objektu. Na testovacim serveru WTLS pro 0.3.8 bylo pridano priblizne 70 objektu a jejich celkova velikost byla 4MB, takze stahovani pribihalo pouze 2 minuty, coz je relativne prijatelne.

Sdílet tento příspěvek


Link to post
Share on other sites

Je pravda, ze nekteri majitele serveru nad tim absolutne nepremysli a pridali by na server stovky zbytecnych objektu a stahovani po pripojeni by trvalo nekolik desitek minut. Kazdopadne me to zruseni hodne mrzi, protoze jsem ztratil skoro dva tydny prace, kterou jsem venoval pridavani featur zalozenych na vlastnich modelech objektu. Na testovacim serveru WTLS pro 0.3.8 bylo pridano priblizne 70 objektu a jejich celkova velikost byla 4MB, takze stahovani pribihalo pouze 2 minuty, coz je relativne prijatelne.

Hele viděl jsem ukázku tvé loďi neboli jachty cos dával na youtube pokud se to nějak vyřeší poběží aspoň na 0.3.7 DL ? 

Sdílet tento příspěvek


Link to post
Share on other sites

V tuhle chvili nemuzu rict jak to bude. Jeste zjistuju nejake informace od beta testeru jak to s tou DL verzi ma byt, ale pokud to bude mozne, tak bych radeji preferoval, aby WTLS bezelo na te DL verzi a myslim si, ze ATomas bude preferovat to same se SP, protoze do vytvareni modelu objektu dal asi taky hodne casu. Tim padem by nemel byt nejspis problem se mezi CZ servery domluvit, ze vsichni budou pouzivat tu DL verzi.

 

Ale problem bude, jestli si hraci budou schopni stahnout tu DL verzi klienta. Pokud totiz na hlavni strance sa-mp.com bude ke stazeni jen obycejna 0.3.7, tak by se treba uplne novy hraci nemuseli dozvedet, ze musi mit stazenou DL verzi, aby mohli hrat na nekterem z CZ serveru. A tim by mohlo pak vzniknout spoustu problemu.

Edited by niCe

Sdílet tento příspěvek


Link to post
Share on other sites

Jedno mi není jasné. Kalcor napsal, že (cituji): "There is lack of interest in the downloading feature by most of the existing SA-MP servers."

 

O kterých serverech to přesně mluvíme? U původního tématu má 100 stránek převážně pozitivních ohlasů, v tom novém tématu též vidím zprávy o velkých či známých serverech, že již na tom pracovali, totéž platí třeba i tady o niCovi... Není ten zakopaný pes v něčem jiném?

Sdílet tento příspěvek


Link to post
Share on other sites

Kvuli nezajmu serveru to nejspis nebude, protoze spoustu velkych serveru zacalo uz pro SA-MP 0.3.8 pripravovat modely objektu a skinu, a to vcetne tech serveru, ktere patri beta testerum (napriklad LS-RP). Zkusil jsem jeste pozadat Kalcora, jestli by vydani SA-MP 0.3.8 neprehodnotil, moje zahranicni servery sice dohromady tvori 3. nejvetsi anglickou SA-MP komunitu, ale i tak si myslim, ze jeho rozhodnuti nikdo nezmeni.

Edited by niCe

Sdílet tento příspěvek


Link to post
Share on other sites

Trochu jsem to jeho strohé vyjádření analyzoval, konkrétně tento odstavec:

Since some servers still want the downloading feature to be available now, 0.3.8 will be re-released as a seperate SA-MP version called 0.3.7-DL, which will be an optional download and have its own server lists. Parts of the existing 0.3.8 code that aren't related to model downloading will make their way in to 0.3.7 updates. Eventually the downloading feature will be part of a main SA-MP release, but the 0.3.8 version will be skipped.

A měl bych k tomu pár postřehů, schválně mi řekněte, zda jsem úplně mimo, nebo by na tom mohlo něco být. Tou poslední větou naznačuje, že vlastní modely tam dříve nebo později budou, ale ne v této (0.3.8) verzi. Otázkou zůstává, proč tomu tak je a proč chce zachovat 0.3.7-DL.

 

Je možné, že to prostě nestíhá a že na to potřebuje další čas. To se bohužel projevilo ve špatnou chvíli – mnoho lidí na tom už začalo aktivně pracovat – proto zachoval tuto 0.3.7-DL větev vývoje.

 

Jestli je tahle domněnka pravdivá, potom tu featuru v některé z dalších verzí zveřejní (možná i v 0.4, koneckonců je to velká změna). Také by to ale znamenalo, že si opět počkáme, a to asi pěkně dlouhou dobu. Otázkou je, zda komunita po tomto šoku a zklamání dalších několik měsíců (nebo spíše let) vydrží čekat.

Sdílet tento příspěvek


Link to post
Share on other sites

V tuhle chvili nemuzu rict jak to bude. Jeste zjistuju nejake informace od beta testeru jak to s tou DL verzi ma byt, ale pokud to bude mozne, tak bych radeji preferoval, aby WTLS bezelo na te DL verzi a myslim si, ze ATomas bude preferovat to same se SP, protoze do vytvareni modelu objektu dal asi taky hodne casu. Tim padem by nemel byt nejspis problem se mezi CZ servery domluvit, ze vsichni budou pouzivat tu DL verzi.

 

Ale problem bude, jestli si hraci budou schopni stahnout tu DL verzi klienta. Pokud totiz na hlavni strance sa-mp.com bude ke stazeni jen obycejna 0.3.7, tak by se treba uplne novy hraci nemuseli dozvedet, ze musi mit stazenou DL verzi, aby mohli hrat na nekterem z CZ serveru. A tim by mohlo pak vzniknout spoustu problemu.

Ano taky jsem na tom nechal nekolik hodin casu. Byt mezi sebou mame neresitelne spory, myslim ze by jsme se mohli domluvit ze my velke servery, spolu se SFDFD protoze ma taky velkou fanovskovskou zakladu prestoupime na 0.3.7-DL. Aby jsme si nekradli hrace napric verzemi.

Sdílet tento příspěvek


Link to post
Share on other sites

Prave vysla verze 0.3.DL R1, ktera je zalozena na posledni verzi 0.3.8 RC4-4. Pokud servery budou chtit vyuzivat vlastni modely objektu, musi stahnout verzi serveru 0.3.DL a hraci pak potrebujou stahnout klienta 0.3.DL.

 

Vice info zde: http://forum.sa-mp.com/showthread.php?p=3984271

Edited by niCe

Sdílet tento příspěvek


Link to post
Share on other sites

Kolik banů nás to stálo, abychom nakonec získali tuto verzi, která je na tom snad ještě hůř než RC. A nesliboval náhodou Kalcor, že prvky nesouvisející s modely budou přidány do hlavní větve? Nakonec jsme dostali nehotovou, nedodělanou, nepropagovanou a téměř nepodporovanou verzi.

A to nepočítám to, že samozřejmě si člověk bude muset jak blbec přeinstalovávat SA-MP, aby mohl používat druhou verzi. Namísto dvou multiplayerů pro SA teď máme tři. Dobrá práce.

Edited by IllidanS4

Sdílet tento příspěvek


Link to post
Share on other sites

Zatim jsem zjistoval od beta teseru SA-MP, na jake verzi chteji mit servery, zatim vsichni odpovedeli ze 0.3.DL. Pockam tedy, jak zareagujou vetsi zahranicni servery a podle toho se rozhodnu, jestli WTLS pobezi take na verzi 0.3.DL. Je to celkem risk, protoze hlavni nevyhoda je, ze naprosta vetsina hracu o teto verzi 0.3.DL nebude vedet, protoze neni odkaz na stazeni na hlavni strance sa-mp.com.

2 hours ago, IllidanS4 said:

Kolik banů nás to stálo, abychom nakonec získali tuto verzi, která je na tom snad ještě hůř než RC. A nesliboval náhodou Kalcor, že prvky nesouvisející s modely budou přidány do hlavní větve? Nakonec jsme dostali nehotovou, nedodělanou, nepropagovanou a téměř nepodporovanou verzi.

A to nepočítám to, že samozřejmě si člověk bude muset jak blbec přeinstalovávat SA-MP, aby mohl používat druhou verzi. Namísto dvou multiplayerů pro SA teď máme tři. Dobrá práce.

Ta verze 0.3.DL je stejna jako 0.3.8 RC4-4. Predpokladam, ze ostatni veci, ktere Kalcor sliboval, ze budou pridany do 0.3.7, vyjdou pozdeji, az probehne nejaky vetsi update serveru a klienta. Vetsina tech veci by totiz vyzadovala povinny update klienta.

Edited by niCe

Sdílet tento příspěvek


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Zde můžete odpovědět na toto téma...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Obnovili jsme váš původní obsah (obsah napsaný před zavřením).   Smazat obnovený obsah

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...